Question:

Set up https magento

Alexander: 5 days ago

I'm trying to get my site to https, but I'm getting file mix error, I made the changes I found there but did not get results. Is there any additional configuration?

ERROR:

Mixed Content: The page at 'https://www.mydomain.com.br/' was loaded over HTTPS, but requested an insecure stylesheet 'http://www.mydomain.com.br/skin/frontend/ultimo/default/css/styles.css'. This request has been blocked; the content must be served over HTTPS.

Magento config

Magento Config

Answer:
Carter: 5 days ago

Force HTTPS throughout the store may fix your issue. You can do that by specifying HTTPS URL in unsecure base URL as well. It may be caused by loading the css with unsecure base URL somewhere in your code directly.

Or just use the condition Mage::app()->getStore()->isCurrentlySecure() to check if HTTPS is enabled and get HTTPS URL for the css declaration you've done.